Home > Без рубрики > Mikrotik в сети Кабинет

Mikrotik в сети Кабинет

Приехал на работу еще один роутер на замену старого хлама – Mikrotik 951g-2hnd. Воспользовавшись ситуацией решил взять домой на выходные, попробовать можно ли подобный роутер использовать дома с возможностью подключения резервных каналов, удобной установкой у входа в квартиру благодаря поддержке POE и прочие плюшки. Единственная загвоздка как и в случае с Asus RT-N56U – это авторизатор моего провайдера. RouterOS несмотря на линуксовские корни закрыта и пересобрать её не представляется возможным, разработчики тоже не пойдут на написания нового модуля для такого низкого спроса. На помощь пришла виртуализация.

Еще одной отличительной особенностью маршрутизаторов Mikrotik – виртуализация дополнительных роутеров, т.е. на железе можно создать до 8 виртуальных роутеров с возможностью установки копий RouterOS либо альтернатив, например OpenWRT. Именно этим я и занялся. Идея проста – создать виртуальный роутер с образом OpenWRT, пробросить в него наш WAN порт и установить и настроить авторизатор провайдера.
Скачиваем образ – openwrt-mr-mips-rootfs.tar.gz. Заходим с помощью winbox на роутер, открываем Files, перетаскиваем туда наш скаченный образ. Открываем раздел MetaRouter, жмём Import Image, памяти можно много не выделять, я ставил 8Мб и все работало стабильно, можно еще ужаться но думаю возможны тормоза.

mkrtkab2

Переходим на вкладку интерфейсов и добавляем в виртуалку наш wan порт.

mkrtkab1

Теперь жмем правой кнопкой мыши на виртуалке и заходим в консоль. Начнем настраивать сеть, приводим файл /etc/conf/network к виду:

 vi /etc/conf/network

# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option proto static
option ipaddr 87.xxx.xxx.xxx – внешний Ip
option netmask 255.255.255.252
option gateway 87.xxx.xxx.1 – соответственно шлюз
list dns 8.8.8.8

Применяем изменения: /etc/init.d/network restart. Теперь мы имеем инет на виртуалке.
Устанавливаем авторизатор:

 cd /bin
wget https://demonx.ru/upload/mkmtr/lanauth
chmod +x lanauth

Пропишем его в автозагрузку:

vi /etc/rc.local
# добавляем туда строку вида
/bin/lanauth -s 10.0.0.1 -p INETPASSWORD -l 2 -v 2

Вот и всё, можно для надежности перезапустить Микротик и убедиться что все работает. Виртуалку можно немного оптимизировать, убрав автосинхронизацию времени и dnsmasq:

chmod -x /etc/init.d/dnsmasq
chmod -x /etc/init.d/sysntpd

Подумал о приобретении такого же маршрутизатора домой и подключении резервного канала, но замеры производительности NAT показали не утешительные результаты для локального (локальной сети провайдера) использования в будущем. Скорость оказалась на уровне 135 Мбит/с при одном потоке. Оно и понятно, в микротике огромные возможности по обработке проходящего трафика, которые процессор просто не может выдержать на высокой скорости. Для 100 мегабитного подключения этого бы хватило, но провайдер в скором времени обещал замену оборудования и обеспечения гигабита. Поэтому остаюсь пока на Asus RT-N56U, он благодаря аппаратному сопроцессору может держать скорость до 850 Мбит/с, естественно без дополнительных плюшек по обработке трафика, как например QoS, фильтрация и прочее.

Tags: mikrotik openwrt router

Comments:2

  1. arxont Ответить
    08.07.2013 at 13:54

    Так если не требуются дополнительные плюшки “как например QoS, фильтрация и прочее”, то может попробовать напрямую к сети провайдера подключится, через чип коммутации? Тогда микротик должен выдать канальную скорость

    • admin Ответить
      08.07.2013 at 16:24

      безусловно, если компьютер один в сети, но у меня ноутбуки, сервера, медиаплееры и прочее оборудование, думаю не рационально приобретать каждому из них свой IP адрес.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *